Vcenter server vpostgr under windows
One environment
Old vcenter Server windows server 2008 R2 + vc6.0
New server windows server 2012 R2 + 6.0
Second explanation
Because there are a lot of things configured on the old vc server, the new server needs to add the host again, and reset the HA, switch, and so on, so you need to back up the database on the old server directly to the new server:
Three operations
Official tutorial: https://kb.vmware.com/s/article/2113647
It basically follows the official tutorial, but there are two things to pay attention to:
1.vpostgres 's account password configuration file vcdb.properties is in the programdata directory, at first thought to be in the vmware installation directory, the official tutorial did not write a complete path. Password is the password.
Vcdb.properties
Path: d:\ ProgramData\ VMware\ vCenterServer\ cfg\ vmware-vpx\ vcdb.properties
Driver = org.postgresql.Driver
Dbtype = PostgreSQL
Url = jdbc:postgresql://localhost:5432/VCDB
Username = vc
Password = 8 (cO {vJPYb+% | 1lX
Password.encrypted = false
two。 Be sure to restart the computer after installing vcenter on the new server. If you do not restart, the database restore script of python will report an error.
Keyerror os.environ ['VMWARE_PYTHON_PATH']
This is because the environment variable has not yet taken effect, and the python cannot be obtained. In fact, the environment variable in the system already exists, but it does not take effect, so it needs to be restarted.