Get the App
SLTechnology News&Howtos  ›  Servers  › 

Jmeter distributed stress testing environment configuration

Shulou Source: shulou.com Published: 2022-06-02 08:21:40 09月30日 Update

Under normal circumstances, if a server has to do a large number of concurrent stress tests of users, it is impossible to withstand, basically jmeter crashes. Now we use the Controller+Agent pattern provided by Jmeter to build a distributed stress testing environment.

Role IP operating system version Controller192.168.10.103Windows 105.1.1Agent192.168.10.210CentOS 75.2.1Agent192.168.10.211CentOS 75.2.1

Note: under normal circumstances, we recommend that all versions of jmeter should be consistent, and if they are inconsistent, the version of Agent should be higher than Controller.

Configuration of the Agent machine:

1. Install JAVA 1.8 JDK (abbreviated)

two。 Download Jmeter

Wget http://mirrors.tuna.tsinghua.edu.cn/apache//jmeter/binaries/apache-jmeter-5.2.1.tgztar zxf apache-jmeter-5.2.1.tgz

3. Close rmi ssl

Sed-I / I

Otherwise, it will show up.

Server failed to start: java.rmi.server.ExportException: Listen failed on port: 0; nested exception is:

Java.io.FileNotFoundException: rmi_keystore.jks (No such file or directory)

An error occurred: Listen failed on port: 0; nested exception is:

Java.io.FileNotFoundException: rmi_keystore.jks (No such file or directory)

4. Configure rmi.server.hostname to modify the

# RMI_HOST_DEF=-Djava.rmi.server.hostname=xxx.xxx.xxx.xxx

Modify to

RMI_HOST_DEF=-Djava.rmi.server.hostname=192.168.10.210 (192.168.10.211 if it is 211)

5. Start jmeter-server

Apache-jmeter-5.2.1/bin/jmeter-server &

Controller machine configuration:

You also need to modify the jmeter.properties file

# server.rmi.ssl.disable=false

Change to server.rmi.ssl.disable=true

And then put the

Remote_hosts=127.0.0.1 is modified to

Remote_hosts=192.168.10.210:1099192.168.10.211:1099

Tags: Configuration file version stress test conformance situation machine distributed environment operating system suggestion server mode user system role build one service Apple Docker Huawei Linux macOS MariaDB Microsoft MySQL NVidia OPPO Reno OPPO Reno Linux MySQL MariaDB NVidia