OpenStack error: Host is not mapped to any cell
Environment description:
Openstack version pike Control Node Host openstack-controller (ubuntu 16.04.5) Compute Node Host openstack-computer (ubuntu 16.04.5) Mirror cirros
Error message:
New instance dt01 reported an error: Host 'openstack-computer' is not mapped to any cell
Solution to the problem:
The control node executes the following command as the stack user:
Stack@openstack-controller:~$ nova-manage cell_v2 discover_hosts-verbose Option "logdir" from group "DEFAULT" is deprecated. Use option "log-dir" from group "DEFAULT". / usr/local/lib/python2.7/dist-packages/pymysql/cursors.py:166: Warning: (1287, u "'@ tx_isolation' is deprecated and will be removed in a future release. Please use'@ @ transaction_isolation' instead") result = self._query (query) Found 2 cell mappings.Skipping cell0 since it does not contain hosts.Getting computes from cell 'cell1': da859b66-f993-4b79-ac58-58009ad27beaFound 0 unmapped computes in cell: da859b66-f993-4b79-ac58-58009ad27bea
Rebuild the instance:
Create a new instance dt04 again:
The instance was created successfully and is located in the openstack-computer node.
At this point, the problem is solved.
Reference: https://ask.openstack.org/en/question/116517/host-is-not-mapped-to-any-cell/
Https://docs.openstack.org/nova/latest/user/cells.html#step-by-step-for-common-use-cases