Platform Harbor-helm, problem record
Deployed a Harbor-helm, high availability deployment to k8s cluster, stable operation for a period of time ~
One day harbor-core and harbor-jog container down, restart failed ~. harbor-core error, roughly the installation of the mirror vulnerability scanning function failed:
[INFO] [/core/api/chart_repository.go:607]: API controller for chart repository server is successfully initialized2019-10-31T05:18:43Z [INFO] [/common/dao/base.go:64]: initialized clair database2019-10-31T05:18:44Z [FATAL] [/core/main.go:231]: failed to initialize clair scanner: api controller: create registration: scanner controller: ping: v1 client: get metadata: Get http://clair-adapter:8080/api/v1/metadata: dial tcp: lookup clair-adapter on 10.43.0.10:53: no such host
Google and the official website did not find the relevant solution, studied for a period of time helpless to give up (the new version pit or more), so ready to revert to the old version.
Delete new version, keep PVC.
helm delete --purge xx
Download Branch 1.2.0 Version:
git clone https://github.com/goharbor/harbor-helm.git --branch=1.2.0
Modify the values.yaml file to add the previous pvc (found two versions of the configuration file except for the mirror version).
installation
helm install , --name xx
harbor-core error, log shows, install database failed, no such file...
goole a while, found that the high version to the lower version of the downgrade, database version inconsistency caused the error...
So replace the PVC of harbor database with a new one and start successfully.
Although the regist mirror is still there (because it is stored in regist's pvc), the harbor page's project information and users are gone.
Open harbor-database with different versions, check the consistency of data structure, and carefully observe the return of one of the table records version number ~
Think test it, modify the high version number 16 to 11, mount and restart, success!