Manually delete 2008R2 subdomain and its domain control
If the sub-domain cannot be degraded due to its own error, delete it manually with ntdsutil.
1 delete subdomain control
Ntdsutil:me cl
Metadata cleanup: con server connections: con to do xx.com server connections: q metadata cleanup: se op tar select operation target: li si select operation target: se si 0 select operation target: li do select operation target: se do 1 select operation target: li se in si select operation target: se se 1 select operation target: q metadata cleanup: re se se
2 delete subdomain
Ntdsutil: me cl
Metadata cleanup: con
Server connections: con to se xx.xx.com (server, not domain)
Server connections: q
Metadata cleanup: se op tar
Select operation target: li si
Select operation target: se si 0
Select operation target: li do
Select operation target: se do 1
Select operation target: li se in si
Select operation target: se se 0
Select operation target: q
Metadata cleanup: re se do
3 if there is an error in deleting a subdomain, you can also delete the subdomain with partition management
Ntdsutil: Partition management
Partition management: con
Server connections: co to se xx.xx.com
Server connections: q
Partition management: li
Partition management: delete nc DC=DomainDnsZones,DC=xx,DC=com
Partition management: delete nc DC=xx,DC=com (the order in which these two lines are deleted cannot be reversed)
4. Delete invalid entries manually from the DNS of the forest root domain control.
5 the above is 0, which represents the forest root domain or its domain control in the list, and 1 represents the subdomain or its domain control. The actual corresponding serial number must be carefully checked during operation.