Sqlserver migrates data
Migrating backup data from sqlserver2000 to sqlserver2005 uses the user corresponding to the database video315 Unable to access the specified database
Error:
User, group, or role 'video315' already exists in the current database. (Microsoft SQL Server, Error: 15023)
Reference: www.cnblogs.com/douxuyao/p/3530052.html
Check sqlserver security-----> video315 attribute in login name. It is found that the database corresponding to the user is unauthorized. Manual authorization cannot take effect.
Executed in a newly created query
use v315db
go
sp_change_users_login 'update_one','video 315','video315' and then test again that you can use user video315 to access the corresponding database v315db
After the operation is completed, check the user authorization is updated