Exchange 2010 Topology Service failed to start (error prompt status = 1919 0x77f Error_No_sitename)
I. Environmental conditions
1 Exchange 2010 + 1 Windows Server 2012 R2 AD.
II. Problem phenomenon
One day, after a sudden power outage in the computer room, restart Exchange and AD. After startup, all AD services and checks are normal. However, Exchange's topology service and other services associated with AD cannot be started. And use commands on the Exchange server
Nltest / dsgetsite could not get the site information, and there was an error prompt status = 1919 0x77f Error_No_sitename
III. Solutions
1. First of all, check whether the domain control server is normal through a series of methods and check commands, and the domain control status is normal after checking.
2. Using the command nltest / dsgetsite on the Exchange server to get the AD site information is wrong.
3. By checking the registry information of the netlogon service on the Exchange server, it is found that there is no site information. (the registry DynamicSiteName key value normally exists, but it is not found in this issue. After manually adding the DynamicSiteName key value, and restarting the Netlogon service, the key value DynamicSiteName will disappear automatically. )
4. In desperation, add SiteName in the following registry key value.
1). Registry location: HKLM\ System\ CurrentControlSet\ Services\ Netlogon\ Parameters
2), create a new "string value", named "SitName", and the attribute value is the AD site where the Exchange server is located.
4. After the registry key value is added, the site information can be successfully obtained by using the command nltest / dsgetsite on the Exchange server, and the Exchange service can be started successfully.