Explain in detail the problem of synchronous repository cache failure after CentOS8 changed yum source
Cause of the problem: at first, the default yum source for CentOS 8 works, but after installing Development Tools with the following command:
Yum groupinstall-y "Development Tools"
I do not know why the synchronization repository cache failure began to occur, and some toolkits could not be installed properly. The error message is as follows:
[root@localhost / etc/yum.repos.d] # yum makecacheCentOS-8.0-AppStream 19 Bsychs | 38 B 00:02 CentOS-8.0-Base 24 Bsychs | 38 B 00:01 CentOS-8.0-Extras 8.4 Bsyn s | 38 B 00:04 synchronization warehouse 'AppStream' cache failed, ignoring this repo. Synchronization repository 'BaseOS' cache failed, ignoring this repo. Synchronization repository 'extras' cache failed, ignoring this repo. The metadata cache has been established. [root@localhost / etc/yum.repos.d] #
So according to the error message, go to the Internet to find the relevant solution, most of which are about changing Ali's yum source, and then changing it as described in the official document:
Https://developer.aliyun.com/mirror/centos
I thought it had been solved smoothly, but I didn't expect that there was still a pit. When the metadata cache was re-established, it still prompted the failure of synchronizing the repository cache:
[root@mesos-master / etc/yum.repos.d] # yum makecacheCentOS-8.0-AppStream-mirrors.aliyun.com 0.0 BUnip s | 0 B 00:24 CentOS-8.0-Base-mirrors.aliyun.com 0.0 BUnip s | 0 B 00:32 CentOS-8.0-Extras-mirrors.aliyun.com 0.0 BUnip s | 0 B 00:32 CentOS-8.0-Epel 2.3 MB/s | 6.0 MB 00:02 WANdisco SVN Repo 1.92.0 kB/s | 121kB 01:01 synchronization repository 'AppStream' cache failed Ignore this repo. Synchronization repository 'base' cache failed, ignoring this repo. Synchronization repository 'extras' cache failed, ignoring this repo. Last metadata expiration check: before 0:00:01, it was performed at 10:26:48 on Monday, March 23, 2020. The metadata cache has been established. [root@mesos-master / etc/yum.repos.d] #
Then puzzled, I thought that the default yum source of the system may not even be connected because of the network, the domestic source should not, ah, is there a problem with the configuration? As it turns out, the $releasever and $basearch placeholders in baseurl are somehow invalid. Therefore, the problem is solved after changing $releasever to 8 and $basearch to x8664. The contents of the modified configuration files are as follows:
# cat CentOS-Base.repo # [base] name=CentOS-8-Base-mirrors.aliyun.comfailovermethod=prioritybaseurl= https://mirrors.aliyun.com/centos/8/BaseOS/x86_64/os/ http://mirrors.aliyuncs.com/centos/8/BaseOS/x86_64/os/ http://mirrors.cloud.aliyuncs.com/centos/8/BaseOS/x86_64/os/gpgcheck=1gpgkey=https://mirrors.aliyun.com/centos/RPM-GPG-KEY-CentOS-Official## # cat CentOS-AppStream.repo # [AppStream] name=CentOS-8-AppStream-mirrors.aliyun.comfailovermethod=prioritybaseurl= https://mirrors.aliyun.com/centos/8/AppStream/x86_64/os/ http://mirrors.aliyuncs.com/centos/8/AppStream/x86_64/os/ http://mirrors.cloud.aliyuncs.com/centos/8/AppStream/x86_64/os/gpgcheck=1gpgkey=https://mirrors.aliyun.com/centos/RPM-GPG-KEY-CentOS-Official### cat CentOS-Extras.repo # [extras] name=CentOS-8-Extras-mirrors.aliyun.comfailovermethod=prioritybaseurl= https://mirrors.aliyun.com/centos/8/extras/x86_64/os/ http://mirrors.aliyuncs.com/centos/8/extras/x86_64/os/ http://mirrors.cloud.aliyuncs.com/centos/8/extras/x86_64/os/gpgcheck=1gpgkey=https://mirrors.aliyun.com/centos/RPM-GPG-KEY-CentOS-Official### cat CentOS- Epel.repo # [epel] name=CentOS-$releasever-Epelbaseurl= http://mirrors.aliyun.com/epel/8/Everything/$basearchenabled=1gpgcheck=0### cat CentOS-PowerTools.repo # [PowerTools] name=CentOS-8-PowerTools-mirrors.aliyun.comfailovermethod=prioritybaseurl= https://mirrors.aliyun.com/centos/8/PowerTools/x86_64/os/ http://mirrors.aliyuncs.com/centos/8/PowerTools/x86_64/os/ http://mirrors.cloud.aliyuncs.com/centos/8/PowerTools / x86 Plus 64Charger gpgcheckaccount 1enabledaccount 0gpgkey= https://mirrors.aliyun.com/centos/RPM-GPG-KEY-CentOS-Official### cat CentOS-centosplus.repo # [centosplus] name=CentOS-8-Plus-mirrors.aliyun.comfailovermethod=prioritybaseurl= https://mirrors.aliyun.com/centos/8/centosplus/x86_64/os/ http://mirrors.aliyuncs.com/centos/8/centosplus/x86_64/os/ http://mirrors.cloud.aliyuncs.com/centos/8/centosplus/x86 _ 64Universe gpgcheckcheck1enabledcards 0gpgkeyword = https://mirrors.aliyun.com/centos/RPM-GPG-KEY-CentOS-Official
After making the above modifications, the problem is resolved, and it is no longer prompted that the synchronization of repository cache failed:
[root@localhost / etc/yum.repos.d] # yum makecacheCentOS-8-AppStream-mirrors.aliyun.com 2.1 MB/s | 6.5 MB 00:03 CentOS-8-Base-mirrors.aliyun.com 1.6 MB/s | 5.0 MB 00:03 CentOS-8-Extras-mirrors.aliyun.com 1.8 kB/s | 4.2 kB 00:02 CentOS-8.0-Epel 2.2 MB/s | 6.0MB 00:02 WANdisco SVN Repo 1.910 kB/s | 121kB 00:11 metadata cache has been established. [root@localhost / etc/yum.repos.d] #
This is the end of this article about the failure of synchronization repository cache after CentOS8 changed yum source. For more information about CentOS8 replacement of yum source synchronization repository failure, please search previous articles or continue to browse the relevant articles below. I hope you will support it in the future!