Handling of failure to encrypt Azure VM disk by PowerShell
The following error was encountered when using the Set-AzVMDiskEncryptionExtension command to encrypt the Azure VM disk: Long running operation failed with status' Failed'. Error Message "Failed to send DiskEncryptionData. Check KeyVault inputs,ResourceIds and RestartTime.
By viewing the error message of the shan overview, the problem should be caused by the fact that the disk encrypted data cannot be written to the key store, and there is no corresponding access policy in the key store, so there is no write permission, so it cannot be written.
With the following command
Set-AzKeyVaultAccessPolicy-VaultName 'atskeyvault'-ResourceGroupName' AzureTS'-EnabledForDiskEncryption sets the relevant policies or enables them in the portal
After the policy is enabled, run the encryption disk command Set-AzVMDiskEncryptionExtension-ResourceGroupName $VMRGname-VMName $vmName-DiskEncryptionKeyVaultUrl $diskEncryptionKeyVaultUrl-DiskEncryptionKeyVaultId $KeyVaultResourceId again and find that the encryption is successful.